Message Boards Message Boards



30 November 2021 2:17
Dear CREODIAS Users,

In the Security section customers will find information about latest and most critical security vulnerabilities, published in the last month by the SANS Institute ( Security vulnerabilities in software and hardware are very often used by cybercriminals to attack IT infrastructure and steal or destroy company's data, that is why companies are advice to fix those vulnerabilities as soon as possible.

ID: CVE-2021-22931
Title: XSS Vulnerability in Nodejs
Vendor: Nodejs
Description: Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dns library which can lead to output of wrong hostnames (leading to Domain Hijacking) and injection vulnerabilities in applications using the library.

ID: CVE-2021-40438
Title: SSRF Vulnerability in Apache Server
Vendor: Apache
Description: A crafted request uri-path can cause mod_proxy to forward the request to an origin server chosen by the remote user. This issue affects Apache HTTP Server 2.4.48 and earlier.

ID: CVE-2021-0236
Title: Denial of Service Vulnerability in Juniper Junos
Vendor: Juniper
Description: An improper check for unusual or exceptional conditions in Juniper Networks Junos OS and Junos OS Evolved Routing Protocol Daemon (RPD) service allows an attacker to send a valid BGP FlowSpec message thereby causing an unexpected change in the route advertisements within the BGP FlowSpec domain leading to disruptions in network traffic causing a Denial of Service (DoS) condition. Continued receipt of these update messages will cause a sustained Denial of Service condition. This issue affects Juniper Networks: Junos OS: All versions prior to 17.3R3-S10 with the exceptions of 15.1X49-D240 on SRX Series and 15.1R7-S8 on EX Series; 17.3 versions prior to 17.3R3-S10; 17.4 versions prior to 17.4R2-S12, 17.4R3-S4; 18.1 versions prior to 18.1R3-S12; 18.2 versions prior to 18.2R2-S8, 18.2R3-S6; 18.3 versions prior to 18.3R3-S4; 18.4 versions prior to 18.4R1-S8, 18.4R2-S6, 18.4R3-S6; 19.1 versions prior to 19.1R1-S6, 19.1R2-S2, 19.1R3-S3; 19.2 versions prior to 19.2R3-S1; 19.3 versions prior to 19.3R2-S5, 19.3R3-S1; 19.4 versions prior to 19.4R1-S3, 19.4R2-S3, 19.4R3; 20.1 versions prior to 20.1R2; 20.2 versions prior to 20.2R1-S3 20.2R2; 20.3 versions prior to 20.3R1-S1, 20.3R2. Junos OS Evolved: All versions prior to 20.3R1-S1-EVO, 20.3R2-EVO.

ID: CVE-2021-42077
Title: SQL injection vulnerability in the PHP Event Calendar
Description: PHP Event Calendar is an AJAX-based, multi-user modern event calendar. It is easy to integrate and fully customizable.
The /server/ajax/user manager.php username parameter in PHP Event Calendar prior to 2021-09-03 allows SQL injection.
This can be used to directly execute SQL statements on the database, allowing an attacker to entirely compromise the database system in some situations. It can also be used to avoid having to fill out the login form.

ID: CVE-2021-42669
Title: Remote Code Execution Vulnerability in Oracle Secure Product Engineers Online Portal system
Description: The Engineers Online Portal system has an uncontrolled file upload vulnerability. An attacker can take advantage of this flaw to gain remote code execution on the vulnerable web server.
​When an avatar is submitted, it goes into the /admin/uploads/ directory, which is accessible to all users. The attacker can get remote code execution on the web server by submitting a simple PHP web shell.

ID: CVE-2021-42237
Title: Remote code execution vulnerability in Sitecore XP 7.5
Description: Sitecore Experience Platform (XP) is a marketing automation solution that carves out personalized customer experiences.
From Sitecore XP 7.5 Initial Release to Sitecore XP 8.2 Update-7, an unsafe deserialization attack makes it possible to execute remote commands on the machine.
To exploit this flaw, no authentication or specific setting is necessary.

ID: CVE-2021-3064
Title: Memory corruption vulnerability in Palo Alto Networks PAN-OS GlobalProtect Portal and Gateway Interfaces
Description: PAN-OS is the software that runs all Palo Alto Network's next-generation firewalls.
The Palo Alto Networks GlobalProtect portal and gateway interfaces are susceptible to a memory corruption vulnerability that allows an unauthenticated network-based attacker to disrupt system processes and potentially execute arbitrary code with root capabilities.
To exploit this flaw, the attacker must have network access to the GlobalProtect interface.
This vulnerability affects PAN-OS 8.1 versions before 8.1.17 but does not affect Prisma Access customers.
ID: CVE-2021-26443
Title: Remote code execution vulnerability in Microsoft Virtual Machine Bus (VMBus)
Description: Microsoft Virtual Machine Bus (VMBus) is a mechanism within the Hyper-V architecture that enables logical communication in partitions. The VMBus works as the internal communications channel to redirect requests to virtual devices, allowing files to be dragged and dropped between the virtual machine and the host.
This vulnerability occurs due to insufficient input validation in VMBus. On the local network, a remote authenticated attacker can send a specially designed communication to the VMBus channel and run arbitrary code on the target system.
Best regards,
0 (0 Votes)